View Single Post
      01-31-2013, 12:30 AM   #6
BMWrules7
Lieutenant Colonel
239
Rep
1,678
Posts

Drives: 2015, 740 LdX, Alpine White
Join Date: Mar 2011
Location: Boston Area

iTrader: (0)

Quote:
Originally Posted by scottg61376
Thanks Rules...

Tried what you stated and still no mas. The file name is UPD05004.bin; downloaded from www.bmw.com/update (so didn't get it from a FTP) apparently this just came out. I also have the BMW Teleservice update path, however the option is greyed out and won't allow me to select it (see screen shots)...



Quote:
Originally Posted by BMWrules7 View Post
Scott,
5
We will get this to work.

Make sure the update file is on the root directory in the USB device.

Next, double check the file name. It should end in .bin

Also, there are newer firmware out there. So, go back and renter the last seven of your vin.

If it still fails, reset idrive by holding round radio volume control in for 30 seconds while engine on and in park.

Finally, if it still fails let me know the exact filename. Confirm that you did not use FTP to grab the file. If you did use FTP, then I will give you a command to use.
Okay, I will check to see if my filename is all cap and the extension is lower case.

By the looks of it, the file may be corrupted. As you might be aware, after you write to a USB stick, you need to flush the buffers so that all of the data are written out.

In other words, when you save the file on to the USB drive and the operation completes there is no guarantee that all of the data are actually on the USB stick.

Why? Because, the operating system does not actually write to the device immediately. Instead, the OS waits for a routine sync operation to take place. This gives you better overall performance.

So, you can tell the OS to flush all buffers and complete all pending writes on the USB stick by ejecting the USB stick. For Windows, click on the little USB icon in the small tray in The lower right hand corner and then eject the correct device. Maybe you ejected the wrong device.

Next, if you have an apple, click the tiny apple in the upper left hand area of your screen. Then select eject or unmount removable media.

In all cases, if you can't eject in Windows or Apple, just select "shutdown" option. Both OS will flush all pending writes to all devices, including USB just before shutting down.

In any event, delete the file on the USB stick and try to download again. Also, try a different USB stick.

The first thing BMW does before installing a firmware update is to compute a checksum. If the checksums don't match, you will get an error similar to what you have. There is a self check routine on the .bin file. Again, it sounds like your file is corrupted. So please retry and be sure to properly "eject" the USB stick.