BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read

Go Back   7Post - 7 Series Forum > BMW 7-Series Forums > (G11) 7-series General Discussions

Post Reply
 
Thread Tools Search this Thread
      03-25-2023, 08:25 PM   #1
BigStan2000
New Member
0
Rep
8
Posts

Drives: 2016 BMW 740i
Join Date: Mar 2023
Location: New Jersey

iTrader: (0)

2016 740i goes back to Park by self

Hi all, I have 2016 740i, intermittently when trying to put into N, D or R, the car goes back into P by self. I can feel gear engaging for a second or 2, verified by scanner, but goes immediately into parking by it self. I have a code 420641 Parking lock: incorrectly applied. Couple of times that it happened, to get it to go into gear i would open the door and then it would go and keep in gear. I dont think its a door problem becase its not showing anything open when door is closed. Tried moving the car in gear with door open and it goes back into parking as its supposed to with warning in dash. Anyone had this problem? Any suggestions? Thank you in advance.
Appreciate 0
      04-21-2023, 08:17 PM   #2
Jackf82
Enlisted Member
0
Rep
47
Posts

Drives: Bmw m4 stage 2
Join Date: Sep 2021
Location: New jersey

iTrader: (0)

Did you ever solve this ? Please let me know how im having the same issue
Appreciate 0
      04-22-2023, 05:09 AM   #3
Raimo5
Private First Class
85
Rep
121
Posts

Drives: BMW 740d xDrive (G11)
Join Date: Feb 2023
Location: Estonia

iTrader: (0)

Does it only not let you select gear or are there other symptoms as well, like going into P by itself during driving, automatic start-stop?
Appreciate 0
      04-23-2023, 11:50 PM   #4
Danyal.N55
Private First Class
Danyal.N55's Avatar
United_States
48
Rep
133
Posts

Drives: BMW X5 and BMW 7 Series
Join Date: Jun 2022
Location: Houston Texas

iTrader: (0)

Garage List
2017 BMW 740i   [10.00]
Ive heard of the electronic Gear Shifter Malfunctioning and shifting between Drive and Park. Maybe try to Disconnect the Battery for 15 Minutes and try? Being electronically controlled the first thing Id do is Disconnect the Battery and Re-Connect it after a while to see what happens.
__________________
Danyal.N55
Appreciate 0
      04-28-2023, 04:58 PM   #5
BigStan2000
New Member
0
Rep
8
Posts

Drives: 2016 BMW 740i
Join Date: Mar 2023
Location: New Jersey

iTrader: (0)

So to update, I've checked oil level at 40C* and was able to put in 3/4 of a Liter. For 2 weeks it did not happen once, always going into D/N/R no problem. I thought it was low oil that solved the problem, but 2 days ago it took about 10 tries of shifting it to get it out of park. From my research it could be solenoids in valve body. They don't have spare parts for gen 2, the only way is to buy full valve body for 4500 from dealer or used solenoids from ebay (green and brown are responsible for parking, I suspect green one is a problem, but not sure, they can be tested with Ohm meter).
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:12 PM.




7post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST