BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   7Post - 7 Series Forum > BMW 7-Series Forums > General 7-series (F01) Discussion

Post Reply
 
Thread Tools Search this Thread
      10-09-2020, 10:10 AM   #1
rajdeep
New Member
0
Rep
6
Posts

Drives: 05 745 LI
Join Date: Nov 2014
Location: NYC

iTrader: (0)

At 107C message engine overheated message

Hello Friends, this is regarding 2005 745LI, I have recently changed coolant Thermostat, Upper and Lower Coolant sensor and Radiator fan. I keep on getting Engine overheated at 107C. The Water pump is working fine as I can c a steady stream of coolant in coolant reservoir. The coolant is between Min and Max range (no coolant leak).

Upper radiator hose is HOT and lower radiator hose is warm to touch.

I am able to drive for 30 mins continuously and the message keeps on popping and disappears and this cycle continues.

Any help is demystifying this issue is much appreciated.

Thank you.
Appreciate 0
      10-09-2020, 01:49 PM   #2
rajdeep
New Member
0
Rep
6
Posts

Drives: 05 745 LI
Join Date: Nov 2014
Location: NYC

iTrader: (0)

I would like to add 1 more thing, I have coolant temperature displayed in my car and even after driving for 30 mins, the the thermostat does not open allowing the cooler coolant in(the thermostat and upper/lower coolant sensors are brand new). The temperature hovers around 107C. Any ideas?
Appreciate 0
      10-14-2020, 10:51 AM   #3
rajdeep
New Member
0
Rep
6
Posts

Drives: 05 745 LI
Join Date: Nov 2014
Location: NYC

iTrader: (0)

Also I have noticed that the radiator Fan does not come on after I get the "Engine has overheated" message. Only after I start the AC, the fan comes on. I can still drive the car with no loss in power or steam issues. Any ideas?
Appreciate 0
      10-15-2020, 01:08 PM   #4
rajdeep
New Member
0
Rep
6
Posts

Drives: 05 745 LI
Join Date: Nov 2014
Location: NYC

iTrader: (0)

Another observation, when I crank up the heater, the cabin gets pretty warm, so that shows the heater core is ok.
Appreciate 0
      10-22-2020, 02:12 PM   #5
rajdeep
New Member
0
Rep
6
Posts

Drives: 05 745 LI
Join Date: Nov 2014
Location: NYC

iTrader: (0)

Any radiator fan fuse or relay should I check for possible issues?
Appreciate 0
      11-23-2020, 01:48 PM   #6
rajdeep
New Member
0
Rep
6
Posts

Drives: 05 745 LI
Join Date: Nov 2014
Location: NYC

iTrader: (0)

I was able to trigger radiator fan at full blast using the BMW ISTA plus software. Is there any other DME or module should I look into to get a better insight into this heating issue?
Appreciate 0
      Yesterday, 03:58 PM   #7
Invincibear
New Member
0
Rep
8
Posts

Drives: 09 BMW 750Li
Join Date: Nov 2020
Location: Canada

iTrader: (0)

You might also want to monitor your oil temps.
As for diagnosing, I mean you've changed out the sensors already and thermostat, maybe there's a blockage in the radiator that allows just enough fluid to pass to make it seem like the system is working? Last things to check are really how much flows through the rad and if it flows well, is the water pump actually working properly. If ISTA kicked on the fan that shows the relay is good.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:38 AM.




7post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST