BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   7Post - 7 Series Forum > BIMMERPOST Universal Forums > General Automotive (non-BMW) Talk + Photos/Videos

Post Reply
 
Thread Tools Search this Thread
      05-16-2019, 11:10 AM   #1
mxchris727
Captain
mxchris727's Avatar
United_States
142
Rep
601
Posts

Drives: E93 335i, E39 (Both 6-speed)
Join Date: Aug 2012
Location: Wilton, CT/Boston, MA

iTrader: (0)

08 Mercedes C350 New Belt Squeaking

Hi All,

My buddy has an 08 C350 that has a rhythmic belt squeak. I have put two new OEM Continental belts on with no change to the sound. As you can see from the video, the sound is in time with the label on the belt. The pulley bearings are fine, so I can't figure this one out. Any ideas?

https://flic.kr/p/2fQUh5u


Thank you!
__________________

BMW GT1 (INPA, DIS, WinKFP, ect..), ISTA/P & /D is up and running! PM me if you want to stop by and code your car.
Appreciate 0
      05-16-2019, 11:48 AM   #2
ScottSinger
Brigadier General
1384
Rep
4,064
Posts

Drives: M235i 6spd
Join Date: Dec 2013
Location: Mid-Atlantic

iTrader: (0)

Been a few years since I worked on my 202 and 203 c-class but belt tensioner seemed to need replacing as if a wear item - but my belt tensioner squeal seemed of longer duration then in the video but I might be mistaken
Appreciate 0
      05-16-2019, 09:52 PM   #3
chassis
Private
chassis's Avatar
United_States
24
Rep
70
Posts

Drives: BMW G01 X3, M-B GLE350W4
Join Date: Mar 2019
Location: Indiana

iTrader: (0)

mbworld dot org
Appreciate 0
      05-16-2019, 10:42 PM   #4
yco
ignorance is bliss..
yco's Avatar
249
Rep
562
Posts

Drives: E71 X6M '10
Join Date: Jan 2018
Location: Istanbul & Kyiv

iTrader: (0)

i never did it by myself but there is a way to check why there is a squeak on the belt and actually most of the time belt is not the reason..

spray some water on the inner side of the belt while engine is running of course.. if you start to hear squeaking higher it has to be a tension issue.. if squeak wont get higher, take out the belt and turn the pulley bearings should turn pretty smooth without any noise and any slack (a bit is ok).. a small slack can cause the noise also..

if its a tension issue after adjusting it to factory setting dont forget the run the engine for at least 5 mins and check it again.. so tension adjusting needs to be done twice not once.. if there is still a sound, tensioner pulley needs to be changed and tension shouldnt stay the same of course after few seconds.. better go for OEM belt also.. it should help you out.. and if there is still some noise turn off the engine and run away from that car..
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:00 PM.




7post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST