BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   7Post - 7 Series Forum > BMW 7-Series Forums > General 7-series (F01) Discussion

Post Reply
 
Thread Tools Search this Thread
      02-16-2021, 12:35 PM   #1
poleary115
New Member
0
Rep
7
Posts

Drives: bmw 750i
Join Date: Jan 2021
Location: texas

iTrader: (0)

Garage List
2009 bmw 750i  [0.00]
2009 750i misfires and code CD9304

Hi, i have a 2009 750i with misfires, changed spark plugs and coils. still had misfires on # 1,3,4,5. changed injectors still have misfires mostly on #1 cylinder. also after changing injectors i have code CD9304, BSD (Bit-Serial Data Interface) bus communications fault Permanent, code will not clear but no other codes.changed #1 injector again but still have the same problem. Please Help
Appreciate 0
      02-16-2021, 12:35 PM   #2
Mdog97
Private
42
Rep
54
Posts

Drives: 2020 330i xDrive
Join Date: Nov 2016
Location: New England

iTrader: (3)

2009 750i misfires and code CD9304

Not that helpful, but I looked at getting one of these (not a 2009, but an N63 powered "hot V" engined 750 just the same) myself a few months ago. My favorite BMW salesperson ran the VIN through the BMW service records system, and saw that there was a "service pack" that had been done on all these engines by BMW without charge. I think it was something to do with replacing parts of the FI system, among other things. This particular car had (inexplicably) NOT had the service pack done, however, so I ran in the opposite direction as fast as I could.

He went on to say that these cars were notorious for having expensive, often intractable electrical gremlins.

Are you doing the work yourself, or having an independent or (gulp) BMW service center do the work?
Appreciate 0
      02-16-2021, 12:35 PM   #3
poleary115
New Member
0
Rep
7
Posts

Drives: bmw 750i
Join Date: Jan 2021
Location: texas

iTrader: (0)

Garage List
2009 bmw 750i  [0.00]
Doing the work myself. The thing is i found some post with this code but they always have another code attached to it. I'm thinking it's the ecm, Was hoping someone could help confirm that for me.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:57 AM.




7post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST