BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read


Go Back   7Post - 7 Series Forum > BMW 7-Series Forums > General 7-series (F01) Discussion

Post Reply
 
Thread Tools Search this Thread
      09-15-2020, 11:42 PM   #1
Bulldog619
New Member
2
Rep
21
Posts

Drives: BMW 740i
Join Date: Sep 2020
Location: San Diego

iTrader: (0)

Help please!!!!!

Hello everyone I am new to Bimmerpost and need your help and input on an issue with my car. I just purchased a new 2020 740i and have been hearing a weird clicking/spring noise whenever I put the car in reverse at slow speed and then brake, it also happens when I drive at slow speeds and tap the brakes. It's really annoying, embarrassing and frustrating. I just want my car to sound normal and not have this issue anymore. If anybody knows what I am experiencing I would greatly appreciate your help as this is driving me crazy! Please give me your input

I have taken the car to BMW of San Diego 3 times and they just cannot figure it out.

Car has 9k Miles.

I have attached a video below of what I am experiencing.


Appreciate 0
      11-26-2020, 04:04 PM   #2
Invincibear
New Member
2
Rep
15
Posts

Drives: 09 BMW 750Li
Join Date: Nov 2020
Location: Canada

iTrader: (0)

Try this at 8:36.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:00 AM.




7post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST